Comment installer des rails sur Ubuntu et mettre à jour Ruby vers la dernière version

Il y a quelques mois, lorsque j'ai appris Ruby-on-Rails pour la première fois, j'ai dû travailler sur un projet collaboratif avec un partenaire de codage. Nous avons continué à rencontrer des problèmes, car il avait une version différente de la configuration de Rails et Buby pour le projet. Je ne pouvais pas comprendre comment installer les versions dont le projet avait besoin.

Voici le guide que j'aurais aimé avoir. Il vous montre également comment changer la version de Ruby ou Rails que vous utilisez, en fonction des projets sur lesquels vous travaillez.

Tout d'abord, installons la dernière version de Ruby. Pour ce faire, nous devons installer un package appelé RVM - Ruby version manager. Ce package nous permet d'installer N'IMPORTE QUELLE version de Ruby sur notre machine Ubuntu et nous permet de basculer entre les versions.

Tout le code ici sera exécuté en utilisant la CLI / terminal Ubuntu.

Installer RVM

  1. Tout d'abord, nous devons installer un pré-requis. Ouvrez votre terminal Ubuntu et tapez la commande:
sudo apt-get install software-properties-common 

Ensuite, nous devons ajouter le PPA (Personal Package archive) . Un PPA est la façon dont nous obtenons des fichiers distribués par des développeurs qui ne sont pas encore arrivés au package / magasin d'applications officiel Ubuntu.

C'est aussi un moyen pour les développeurs de distribuer les dernières versions de leurs logiciels en attendant qu'Ubuntu teste et publie ce logiciel dans la boutique officielle.

sudo apt-add-repository -y ppa:rael-gc/rvm

La commande ci-dessus ajoute le PPA à la liste des emplacements à partir desquels nous pouvons télécharger des packages sur notre machine Ubuntu.

Ensuite, actualisons notre liste de packages en exécutant:

sudo apt-get update

Enfin, installons RVM lui-même.

sudo apt-get install rvm

Redémarrez maintenant votre terminal pour que vos modifications prennent effet. Ensuite, tapez rvm versionet appuyez sur enterpour vérifier que rvm est installé. Vous devriez obtenir une réponse comme celle-ci:

rvm 1.29.10 (manual) by Michal Papis, Piotr Kuczynski, Wayne E. Seguin [//rvm.io]

Installer Ruby

Nous pouvons maintenant installer la dernière version de Ruby qui est la 2.7.1. Exécutez la commande rvm install 2.7.1. Alternativement, vous pouvez exécuter rvm install rubyqui installera la dernière version stable (cela installera la v2.7.0).

Pour voir quelles versions de Ruby vous avez installées, exécutez rvm ls. Pour basculer entre les versions de Ruby, exécutez rvm use (par exemple, rvm use 2.7.1).

Installation de Ruby-on-Rails

La dernière version de Rails est à 6.03. Rails est simplement un joyau Ruby, et avec Ruby installé, nous pouvons installer Rails! Exécutez gem install railspour installer la dernière version de Rails.

Enfin, pour vérifier que tout s'est bien passé, exécutez rails -v. Vous devriez Rails 6.0.3.2revenir, car il s'agit de la dernière version au moment de la publication de cet article.

Vous pouvez maintenant démarrer votre premier projet Rails en tapant rails new myapp.

Hé, tu es maintenant sur Rails!